Package: accerciser / 3.22.0-7

Metadata

Package Version Patches format
accerciser 3.22.0-7 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_remove_site_package_version.patch | (download)

src/accerciser.in | 4 0 + 4 - 0 !
1 file changed, 4 deletions(-)

 remove hardcoded python version from startup script


02_ipython5.patch | (download)

plugins/ipython_view.py | 10 7 + 3 - 0 !
1 file changed, 7 insertions(+), 3 deletions(-)

 ipython: update to support ipython version 5

commit 5a3242b4c7f5a5c844a20821881d68d1cabcae1e

Bug-Debian: https://bugs.debian.org/848119
Bug: https://bugzilla.gnome.org/show_bug.cgi?776301

03_get_image.patch | (download)

src/lib/accerciser/node.py | 33 16 + 17 - 0 !
1 file changed, 16 insertions(+), 17 deletions(-)

 fix accessing items without a compositor

Bug-Debian: https://bugs.debian.org/875629

Python 3.7 support async is a keyword.patch | (download)

src/lib/accerciser/accerciser.py | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 python 3.7+ support, async is a keyword

    File "accerciser/accerciser.py", line 106
      pyatspi.Registry.start(async=True, gil=False)
                                 ^
    SyntaxError: invalid syntax