Package: acedb / 4.9.39+dfsg.02-5

hardening.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Author: Andreas Tille <tille@debian.org>
Last-Update: Thu, 10 Dec 2015 15:24:16 +0100
Description: Propagate hardening options

--- a/wmake/LINUX_64_DEF
+++ b/wmake/LINUX_64_DEF
@@ -23,9 +23,9 @@ LIBCC = gcc
 COPT = -g
 GTKVER = glib-2.0 gtk+-2.0
 
-COMPILER = gcc $(COPT) -Wall  -DACEDB4 `../w3rdparty/include-config $(GTKVER)`
+COMPILER = gcc $(COPT) -Wall  -DACEDB4 `../w3rdparty/include-config $(GTKVER)` $(CLFAGS)
 
-LINKER = gcc $(COPT)
+LINKER = gcc $(COPT) $(LDFLAGS)
 
 # The arg to libs-config is used if our private copy not installed.
 LIBS = -L/usr/X11R6/lib `../w3rdparty/libs-config $(GTKVER)` -lm -lreadline -lX11
--- a/wmake/LINUX_4_DEF
+++ b/wmake/LINUX_4_DEF
@@ -23,9 +23,9 @@ LIBCC = gcc
 COPT = -g
 GTKVER = glib-2.0 gtk+-2.0
 
-COMPILER = gcc $(COPT) -Wall  -DACEDB4 `../w3rdparty/include-config $(GTKVER)`
+COMPILER = gcc $(COPT) -Wall  -DACEDB4 `../w3rdparty/include-config $(GTKVER)` $(CFLAGS)
 
-LINKER = gcc $(COPT)
+LINKER = gcc $(COPT) $(LDFLAGS)
 
 # The arg to libs-config is used if our private copy not installed.
 LIBS = -L/usr/X11R6/lib `../w3rdparty/libs-config $(GTKVER)` -lm -lreadline -lX11