Package: agg / 2.5+dfsg1-11

Metadata

Package Version Patches format
agg 2.5+dfsg1-11 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01 disable gpc.patch | (download)

Makefile.am | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 disable gpc at build time.

02 maintainer mode.patch | (download)

configure.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use am_maintainer_mode, to avoid re-running autotools 
 except when explicitely called in debian/rules.

03 pkg config pic.patch | (download)

libagg.pc.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 correct library name from agg to agg_pic for link

04 no rpath.patch | (download)

libagg.pc.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable hard coded rpath during linking

05 fix recursion crash.patch | (download)

include/agg_rasterizer_cells_aa.h | 6 6 + 0 - 0 !
1 file changed, 6 insertions(+)

 avoid a crash caused by an infinite recursion when 
 drawing extremely long lines. (LP #344849)

06 fix missing includes.patch | (download)

include/agg_rasterizer_cells_aa.h | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 add missing includes for fix compile. (lp #393923)

07 autogen noconfigure.patch | (download)

autogen.sh | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable configure's run from the autogen file.

08 fix kfreebsd ftbfs.patch | (download)

src/Makefile | 7 6 + 1 - 0 !
1 file changed, 6 insertions(+), 1 deletion(-)

 patch to prevent a ftbfs on kfreebsd-*

09 fix hurd ftbfs.patch | (download)

src/Makefile | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 patch to prevent a ftbfs on gnu/hurd.

10 FTBFS AM_C_PROTOTYPES support.patch | (download)

autogen.sh | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 ftbfs am_c_prototypes support

Build fails because of "error: automatic de-ANSI-fication support has been
removed" during the ./autogen.sh call when aclocal-1.15 and automake-1.15
is used. But the control file expects automake/aclocal-1.11 to be
installed. So enforce the call to these version of tools instead of the
versions selected as default by the system.

Bug-Debian: https://bugs.debian.org/822544