Package: akonadi / 4:16.04.3-4

Metadata

Package Version Patches format
akonadi 4:16.04.3-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
postgresql data checksums.patch | (download)

src/server/storage/dbconfigpostgresql.cpp | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 postgresql-data-checksums


set_dependency_order.diff | (download)

autotests/akonadicontrol/CMakeLists.txt | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 set_dependency_order


QSqlite3 fix build with Qt 5.7.patch | (download)

CMakeLists.txt | 6 3 + 3 - 0 !
src/qsqlite/CMakeLists.txt | 2 2 + 0 - 0 !
src/qsqlite/src/QtSql/private/qobject_p.h | 434 0 + 434 - 0 !
src/qsqlite/src/QtSql/private/qsqlcachedresult_p.h | 100 0 + 100 - 0 !
src/qsqlite/src/QtSql/private/qsqldriver_p.h | 86 0 + 86 - 0 !
src/qsqlite/src/qsql_sqlite.cpp | 70 54 + 16 - 0 !
6 files changed, 59 insertions(+), 639 deletions(-)

 [patch] qsqlite3: fix build with qt 5.7

Use ${QtSql_PRIVATE_INCLUDE_DIRS} to include the private headers
directly from current Qt install instead of carrying a local copy.

kubuntu_disable_secure_file_priv_check.diff | (download)

src/server/storage/mysql-global.conf | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 disable the secure_file_priv check
 MySQL 5.7 introduced a premission check for export and import operations.
 In Ubuntu, only the full mysql-server package creates the set system wide
 directory causing mysqld-akonadi to error out on startup if only
 mysql-server-core-5.7 is installed.
 To prevent that the key is set to empty, which reverts mysqld to the 5.6
 behavior.
 See http://dev.mysql.com/doc/refman/5.7/en/server-system-variables.html#sysvar_secure_file_priv