Package: alienblaster / 1.1.0-10

07-fix_as_needed_build.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Description: fix build with --as-needed
 the libraries must be behind the object files needing them
Author: Julian Taylor <jtaylor.debian@googlemail.com>
Index: alienblaster-1.1.0/src/Makefile
===================================================================
--- alienblaster-1.1.0.orig/src/Makefile	2011-06-29 17:46:42.126858807 +0200
+++ alienblaster-1.1.0/src/Makefile	2011-06-29 17:46:57.836858813 +0200
@@ -47,7 +47,7 @@
 	@echo ""
 	@echo ""
 	@echo "Linking $@"
-	@$(COMPILER) $(GAME_LIBS) -o $(GAME_NAME) $(OBJECT_FILES)
+	@$(COMPILER) -o $(GAME_NAME) $(OBJECT_FILES) $(GAME_LIBS)
 	mv $(GAME_NAME) ../
 
 %.o: %.cc