Package: anki / 2.1.8+dfsg-1

Metadata

Package Version Patches format
anki 2.1.8+dfsg-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
no version nag | (download)

aqt/main.py | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 disable check for new upstream version
 The Debian packaged anki should not keep notifying the user about new upstream
 versions.  For the user, Debian is upstream and new versions of the package
 would be found through the usual channels (e.g. aptitude).
paths | (download)

anki/lang.py | 14 2 + 12 - 0 !
aqt/__init__.py | 2 1 + 1 - 0 !
2 files changed, 3 insertions(+), 13 deletions(-)

 set file paths to the installed locations
 Currently the locale files are diverted from the upstream location, so the
 directory for the gettext files is simply set to /usr/share/locale.
default locale | (download)

aqt/profiles.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use getlocale(lc_messages) for default interface locale
 It will use LANG if LC_MESSAGES is not set and return no locale if neither is
 set. Using getdefaultlocale() will yield possibly undesired locales if other
 LC_* fields are set.


uninline javascript | (download)

aqt/mediasrv.py | 5 5 + 0 - 0 !
aqt/webview.py | 20 19 + 1 - 0 !
2 files changed, 24 insertions(+), 1 deletion(-)

 replace minified javascript with references to libjs packages
 The Javascript packages in the original anki.js are minified versions
 of JQuery and other packages without their corresponding sources.
 The dfsg repackaging of the source archive removes this content,
 so this patch adds hooks into files provided by the relevant libjs-*
 packages.  The provided "plot.js" file is a concatenation of three
 files from the FLOT software, so this patch pulls in all three of
 them from the libjs-jquery-flot package.