Package: antimony / 0.9.3-2

Metadata

Package Version Patches format
antimony 0.9.3-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
bugged_parsercheck | (download)

lib/fab/src/tree/v2syntax.y | 9 0 + 9 - 0 !
1 file changed, 9 deletions(-)

 remove bugged lemon parser
 See https://github.com/mkeeter/antimony/issues/196 for more info.
 .
 antimony (0.9.3) testing; urgency=low
 .
   * Initial packaging. Based on Peter Felecan <peter@felecan.org> package work
    from upstream repository. (Closes: #907435)
0002 Use new CMake Python discovery with matching Boost P.patch | (download)

CMakeLists.txt | 20 2 + 18 - 0 !
app/CMakeLists.txt | 2 1 + 1 - 0 !
lib/fab/CMakeLists.txt | 6 3 + 3 - 0 !
lib/graph/CMakeLists.txt | 6 3 + 3 - 0 !
4 files changed, 9 insertions(+), 25 deletions(-)

 use new cmake python discovery, with matching boost::python abi.

CMake has a new Python discovery module, that can also export
major/minor version numbers. Switch to using it.

Boost, has also moved on to standard pythonXY abi component name
across all distributions/OS, thus use matching version ABI.

If one wants to compile against much older Boost, I guess we could add
fallback to search for Boost python3 component, but IMHO this should
not be necessory.

0003 Change python variable in cmake.patch | (download)

app/CMakeLists.txt | 2 1 + 1 - 0 !
lib/fab/CMakeLists.txt | 4 2 + 2 - 0 !
lib/graph/CMakeLists.txt | 4 2 + 2 - 0 !
3 files changed, 5 insertions(+), 5 deletions(-)

 change python variable in cmake


0004 Import QPainterPath.patch | (download)

app/canvas/connection/base.h | 1 1 + 0 - 0 !
app/viewport/control/control.h | 1 1 + 0 - 0 !
app/viewport/control/control_instance.h | 1 1 + 0 - 0 !
3 files changed, 3 insertions(+)

---