Package: aptly / 1.3.0+ds1-2.2

Metadata

Package Version Patches format
aptly 1.3.0+ds1-2.2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
kjk lzma.patch | (download)

deb/deb.go | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use debian's lzma package.
pborman uuid.patch | (download)

deb/contents.go | 2 1 + 1 - 0 !
deb/local.go | 2 1 + 1 - 0 !
deb/publish.go | 2 1 + 1 - 0 !
deb/remote.go | 2 1 + 1 - 0 !
deb/snapshot.go | 2 1 + 1 - 0 !
files/package_pool.go | 2 1 + 1 - 0 !
6 files changed, 6 insertions(+), 6 deletions(-)

 use debian's uuid package.
Fix UUID struct field not encoded in msgpack.patch | (download)

deb/local.go | 4 2 + 2 - 0 !
deb/snapshot.go | 6 3 + 3 - 0 !
2 files changed, 5 insertions(+), 5 deletions(-)

 golang-github-ugorji-go-codec-dev 1.1.1 takes the json field tag
 by default, thus the field which has `json:"-"` is ignored when
 marshal into msgpack.
Upstream uses the old codec library, so there's no problem.
Bug-Debian: https://bugs.debian.org/923866
Fix time.Time msgpack decoding backwards compatibili.patch | (download)

deb/remote.go | 3 2 + 1 - 0 !
deb/snapshot.go | 3 2 + 1 - 0 !
2 files changed, 4 insertions(+), 2 deletions(-)

 fix time.time msgpack decoding backwards compatibility

This allows aptly to decode DB created by old codec library.