Package: autoconf / 2.69-8

Metadata

Package Version Patches format
autoconf 2.69-8 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
atomic.patch | (download)

bin/autom4te.in | 17 15 + 2 - 0 !
1 file changed, 15 insertions(+), 2 deletions(-)

 make autom4te atomically replace its output file.
stricter versioning.patch | (download)

bin/autom4te.in | 3 2 + 1 - 0 !
lib/Autom4te/C4che.pm | 14 13 + 1 - 0 !
2 files changed, 15 insertions(+), 2 deletions(-)

 invalidate the autom4te cache more aggressively.
 Upstream only invalidates the Autom4te cache if it is older than
 auto4mte, but this only works well if the autom4te binary date
 reflects the date when it was installed.  In debian, the autom4te
 binary date is instead the date when it was built, which doesn't
 guarantee that caches will be properly invalidated.
 .
 Upstream may be interested, but requested some changes that have not
texinfo.patch | (download)

doc/autoconf.texi | 24 12 + 12 - 0 !
1 file changed, 12 insertions(+), 12 deletions(-)

 fix build error with texinfo 5.1.
 Backported from a patch applied upstream.
avoid undefined behavior for 32bit off_t.patch | (download)

lib/autoconf/specific.m4 | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix undefined behavior for 32-bit off_t.
 autoconf (2.69-6) unstable; urgency=low
 .
   * lib/autoconf/specific.m4: Use ((off_t) 1 << 31) << 31 in place of
     (off_t) 1 << 62 to avoid undefined behavior when off_t is 32-bit.
     Closes: #742780.  Thanks to Mathieu Malaterre <malat@debian.org> for
     reporting this bug.
AM_PROG_LIBTOOL.patch | (download)

bin/autoreconf.in | 2 2 + 0 - 0 !
lib/autom4te.in | 1 1 + 0 - 0 !
2 files changed, 3 insertions(+)

 make autoreconf recognize am_prog_libtool too
 .
 during the "getting the main packages ready"-campaign for ppc64el I
 noticed that dh-autoreconf doesn't work if a package uses
 AM_PROG_LIBTOOL but works with AC_PROG_LIBTOOL though both makros
 should behave the same (and are both deprecated) according to
 http://www.gnu.org/software/libtool/manual/html_node/LT_005fINIT.html
 A sample package for this is version 0.4.5+cvs20030824-7 of smpeg (I
 will upload an NMU now for that package, because it prevents the build
 of kde4libs).
 .
 The following patch changes this behaviour, and would save quite many
 sourceful uploads, so I'd ask you to check the fix and if applicable
 upload it soon. That would really be a great help for this / all
 future ports of Debian (though of course packages should be fixed to
 not use deprecated macros, but that's something else).