Package: baloo / 4:4.14.3-3

Metadata

Package Version Patches format
baloo 4:4.14.3-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
disable_tests_depending_on_revdep | (download)

src/pim/agent/autotests/CMakeLists.txt | 48 24 + 24 - 0 !
src/pim/akonadiplugin/autotests/CMakeLists.txt | 54 27 + 27 - 0 !
2 files changed, 51 insertions(+), 51 deletions(-)

---
upstream_Set cmake_minimum_required to set the cmake policies.patch | (download)

CMakeLists.txt | 2 2 + 0 - 0 !
src/file/autotest/fileindexingjob/CMakeLists.txt | 3 1 + 2 - 0 !
2 files changed, 3 insertions(+), 2 deletions(-)

 [patch] set cmake_minimum_required to set the cmake policies.

Otherwise future changes in cmake can break compilation.

upstream_baloofiles was missing the EXPORT that other libs ha.patch | (download)

src/file/lib/CMakeLists.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch] baloofiles was missing the export that other libs have

This led to "ld: cannot find -lbaloofiles" in nepomuk-core.