Package: banshee / 2.6.2-6.1

Metadata

Package Version Patches format
banshee 2.6.2-6.1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
Debrand the interface to Netbook.patch | (download)

src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoPanel.cs | 12 6 + 6 - 0 !
src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoService.cs | 2 1 + 1 - 0 !
2 files changed, 7 insertions(+), 7 deletions(-)

 debrand the interface to "netbook"

Upstream bug report: https://bugzilla.gnome.org/show_bug.cgi?id=623588

Only show panel on client MeeGo and don t show when .patch | (download)

src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoService.cs | 4 3 + 1 - 0 !
1 file changed, 3 insertions(+), 1 deletion(-)

 only show panel on --client=meego and don't show when banshee is
 called

Bug: https://bugzilla.gnome.org/show_bug.cgi?id=623588

Quit only on explicit shutdown request.patch | (download)

src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoService.cs | 5 0 + 5 - 0 !
1 file changed, 5 deletions(-)

 quit only on explicit shutdown request

Bug: https://bugzilla.gnome.org/show_bug.cgi?id=623588

Enable switching between the 2 interfaces.patch | (download)

src/Core/Banshee.ThickClient/Resources/core-ui-actions-layout.xml | 1 1 + 0 - 0 !
src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoPanel.cs | 9 9 + 0 - 0 !
src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoService.cs | 42 39 + 3 - 0 !
3 files changed, 49 insertions(+), 3 deletions(-)

 enable switching between the 2 interfaces

This enables switching between the 2 interfaces, even when the classic interface
is started.

Add Meego desktop file.patch | (download)

src/Extensions/Banshee.MeeGo/Makefile.am | 10 7 + 3 - 0 !
src/Extensions/Banshee.MeeGo/banshee.desktop.in.in | 11 11 + 0 - 0 !
2 files changed, 18 insertions(+), 3 deletions(-)

 add meego desktop file


Enable MPRIS extension by default.patch | (download)

src/Extensions/Banshee.Mpris/Banshee.Mpris.addin.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 enable mpris extension by default


Remove irrelevant media.patch | (download)

src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MediaPanelContents.cs | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 remove irrelevant media


libossifer Fix certificate validation with libsoup 2.patch | (download)

build/m4/banshee/libwebkit.m4 | 7 7 + 0 - 0 !
src/Core/Banshee.WebBrowser/libossifer/ossifer-session.c | 6 6 + 0 - 0 !
2 files changed, 13 insertions(+)

 libossifer: fix certificate validation with libsoup 2.38 (bgo#673037)

Libsoup 2.38 added a new SOUP_SESSION_SSL_USE_SYSTEM_CA_FILE property,
which tells it to use the default system CA database. If we don't set
it, all SSL validations fail.

Add dllmaps for Banshee.NowPlaying.X11.dll.patch | (download)

src/Backends/Banshee.NowPlaying.X11/Banshee.NowPlaying.X11.dll.config | 3 3 + 0 - 0 !
src/Backends/Banshee.NowPlaying.X11/Makefile.am | 1 1 + 0 - 0 !
2 files changed, 4 insertions(+)

 add dllmaps for banshee.nowplaying.x11.dll


Initial port to GStreamer 1.0.patch | (download)

build/m4/banshee/gstreamer.m4 | 19 10 + 9 - 0 !
data/audio-profiles/wav.xml.in | 5 1 + 4 - 0 !
libbanshee/banshee-bpmdetector.c | 11 6 + 5 - 0 !
libbanshee/banshee-gst.h | 4 3 + 1 - 0 !
libbanshee/banshee-player-cdda.c | 5 3 + 2 - 0 !
libbanshee/banshee-player-dvd.c | 4 2 + 2 - 0 !
libbanshee/banshee-player-equalizer.c | 4 2 + 2 - 0 !
libbanshee/banshee-player-missing-elements.c | 2 1 + 1 - 0 !
libbanshee/banshee-player-pipeline.c | 37 18 + 19 - 0 !
libbanshee/banshee-player-private.h | 13 8 + 5 - 0 !
libbanshee/banshee-player-replaygain.c | 29 11 + 18 - 0 !
libbanshee/banshee-player-video.c | 89 43 + 46 - 0 !
libbanshee/banshee-player-vis.c | 88 28 + 60 - 0 !
libbanshee/banshee-player.c | 11 4 + 7 - 0 !
libbanshee/banshee-ripper.c | 16 6 + 10 - 0 !
libbanshee/banshee-tagger.c | 2 1 + 1 - 0 !
libbanshee/banshee-transcoder.c | 19 9 + 10 - 0 !
17 files changed, 156 insertions(+), 202 deletions(-)

 initial port to gstreamer 1.0


Remove build time enable gapless playback option.patch | (download)

configure.ac | 15 0 + 15 - 0 !
libbanshee/Makefile.am | 4 0 + 4 - 0 !
libbanshee/banshee-player-pipeline.c | 4 0 + 4 - 0 !
libbanshee/banshee-player.c | 10 0 + 10 - 0 !
src/Backends/Banshee.GStreamer/Banshee.GStreamer/PlayerEngine.cs | 32 10 + 22 - 0 !
src/Backends/Banshee.GStreamer/Makefile.am | 4 0 + 4 - 0 !
src/Backends/Banshee.GStreamerSharp/Makefile.am | 4 0 + 4 - 0 !
7 files changed, 10 insertions(+), 63 deletions(-)

 remove build-time --enable-gapless-playback option

This was previously added to check for a new enough playbin, but since we're now
using Gstreamer 1.0, the playbin version should be new enough, and we can drop
the conditionals.

Don t use the new decoded pad signal of decodebin.patch | (download)

libbanshee/banshee-bpmdetector.c | 8 4 + 4 - 0 !
libbanshee/banshee-transcoder.c | 8 4 + 4 - 0 !
2 files changed, 8 insertions(+), 8 deletions(-)

 don't use the new-decoded-pad signal of decodebin

It is not available anymore in 1.0 and pad-added should be used.

Use new style GStreamer 1.0 raw audio caps in the WA.patch | (download)

data/audio-profiles/wav.xml.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use new-style gstreamer 1.0 raw audio caps in the wav audio profile


Use dbus 2.patch | (download)

build/m4/banshee/dbus.m4 | 4 2 + 2 - 0 !
build/pkg-config/banshee-collection-indexer.pc.in | 2 1 + 1 - 0 !
build/pkg-config/banshee-core.pc.in | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.ServiceStack/DBusServiceManager.cs | 5 1 + 4 - 0 !
4 files changed, 5 insertions(+), 8 deletions(-)

 use dbus# 2


Remove IDBusExportable inheritance from exported int.patch | (download)

src/Core/Banshee.Services/Banshee.MediaEngine/IPlayerEngineService.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.MediaEngine/PlayerEngineService.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.PlaybackController/IPlaybackControllerService.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.PlaybackController/PlaybackControllerService.cs | 4 2 + 2 - 0 !
src/Core/Banshee.Services/Banshee.Sources/ISourceManager.cs | 2 1 + 1 - 0 !
src/Core/Banshee.ThickClient/Banshee.Gui/GlobalActions.cs | 2 1 + 1 - 0 !
src/Core/Banshee.ThickClient/Banshee.Gui/IClientWindow.cs | 2 1 + 1 - 0 !
src/Core/Banshee.ThickClient/Banshee.Gui/IGlobalUIActions.cs | 4 2 + 2 - 0 !
8 files changed, 10 insertions(+), 10 deletions(-)

 remove idbusexportable inheritance from exported interfaces

This fixes the crashes when attempting to control an existing instance of
Banshee using the command-line interface.

Bug-Debian: #731978
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=725446

Database fix performance for the new SQLite s query .patch | (download)

src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseAlbumArtistListModel.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseAlbumListModel.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseArtistListModel.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseFilterListModel.cs | 7 4 + 3 - 0 !
src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseQueryFilterModel.cs | 5 3 + 2 - 0 !
src/Core/Banshee.Services/Banshee.Collection.Database/DatabaseYearListModel.cs | 2 1 + 1 - 0 !
src/Core/Banshee.Services/Banshee.Database/BansheeDbConnection.cs | 10 10 + 0 - 0 !
7 files changed, 21 insertions(+), 9 deletions(-)

 database: fix performance for the new sqlite's query planner
 (bgo#740879)

Starting with sqlite version 3.8.6, a new query planner is used.
To get back the performance on filling the CoreCache Table,
this commit provides hints to sqlite (using the UNLIKELY statement).
But the UNLIKELY statement is only supported in version 3.8.1 and
above, so in order not to raise the version of the dependency on
sqlite, we can use this new clause conditionally.

Fix sqlite likelihood_support detection.patch | (download)

src/Core/Banshee.Services/Banshee.Database/BansheeDbConnection.cs | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

 fix sqlite likelihood_support detection

"SELECT sqlite_version () >= '3.8.1'" does not return 1 when
sqlite_version () is 3.10.x and above.

build Remove obsolete check for gnome desktop 2.0 2..patch | (download)

configure.ac | 7 2 + 5 - 0 !
1 file changed, 2 insertions(+), 5 deletions(-)

 build: remove obsolete check for gnome-desktop-2.0 >= 2.28

The check was just used to put the right name in the .desktop file. We
keep the check for MeeGo to still do the right thing there.

mono 4.5.patch | (download)

build/m4/shamrock/mono.m4 | 5 5 + 0 - 0 !
configure.ac | 4 2 + 2 - 0 !
2 files changed, 7 insertions(+), 2 deletions(-)

 find 4.5 versions of required assemblies