Package: bubblewrap / 0.4.1-3

Metadata

Package Version Patches format
bubblewrap 0.4.1-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
Correct name of PR_SET_NO_NEW_PRIVS in error message.patch | (download)

bubblewrap.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 correct name of pr_set_no_new_privs in error message

Signed-off-by: Simon McVittie <smcv@collabora.com>
Add MS_SILENT to most mount invocations.patch | (download)

bind-mount.c | 6 3 + 3 - 0 !
bubblewrap.c | 6 3 + 3 - 0 !
2 files changed, 6 insertions(+), 6 deletions(-)

 add ms_silent to most mount() invocations

There's an effort to migrate Linux filesystems to handle the y2038
problem, which is great.  However, recently a kernel change landed
that emits a warning when mounting a filesystem that doesn't
handle it, and this notably shows up even when *remounting* e.g.
for a read-only bind mount:

Using e.g. `rpm-ostree install cowsay` there's a spam of:

```
[  189.529594] xfs filesystem being remounted at /sysroot supports timestamps until 2038 (0x7fffffff)
```

Now particularly when creating a our bind mounts, let's
ask the kernel to be quiet about it.  This is not a major event
worthy of a kernel log.

Accept EROFS for access check of proc entries.patch | (download)

bubblewrap.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 accept erofs for access() check of /proc entries

This is required to work in a Docker container.

Use Python 3 for test demo code.patch | (download)

demos/userns-block-fd.py | 2 1 + 1 - 0 !
tests/test-run.sh | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 use python 3 for test/demo code

Python 2 EOL was a year ago, and distributions like Debian no longer
have a /usr/bin/python executable.

Signed-off-by: Simon McVittie <smcv@collabora.com>
Fix typos for descendant in man page.patch | (download)

bwrap.xml | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix typos for "descendant" in man page

Detected by Debian's Lintian tool.

Signed-off-by: Simon McVittie <smcv@collabora.com>
debian/Change EPERM error message to show Debian specific inform.patch | (download)

bubblewrap.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 change eperm error message to show debian-specific information