Package: bundler / 2.1.4-2~bpo10+1

Metadata

Package Version Patches format
bundler 2.1.4-2~bpo10+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0002 Replace bundled libraries with system versions.patch | (download)

lib/bundler/vendored_molinillo.rb | 2 1 + 1 - 0 !
lib/bundler/vendored_thor.rb | 4 2 + 2 - 0 !
2 files changed, 3 insertions(+), 3 deletions(-)

 replace bundled libraries with system versions
0004 block phone call to check if latest release closes 8.patch | (download)

lib/bundler/cli.rb | 5 5 + 0 - 0 !
1 file changed, 5 insertions(+)

 block "phone call" to check if latest release (closes: #882361)

This is not the ideal solution yet, as it does not let the user unset
disable_version_check to force-check. Should be fixed

use_specific_receiver_for_require_inside_bundler_module.patch | (download)

lib/bundler/vendored_thor.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use explicit receiver for `require` inside `bundler` module
 Bundler has a `Bundler.require` method, so we need to use a explicit
 receiver here so that we don't end up calling the wrong method.