Package: bzr-loom / 2.2.0-5

root_inventory.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Description: Adjust for API change in bzr 2.5
Author: Colin Watson <cjwatson@ubuntu.com>
Forwarded: no
Last-Update: 2012-10-09

Index: b/branch.py
===================================================================
--- a/branch.py
+++ b/branch.py
@@ -170,7 +170,7 @@
         :param loom_content_lines: the unicode content to be used for the loom.
         """
         self._inventory = bzrlib.inventory.Inventory()
-        self.inventory.add(loom_meta_ie)
+        self.root_inventory.add(loom_meta_ie)
         self._loom_stream = loom_stream
         self._loom_sha1 = loom_sha1
     
Index: b/version.py
===================================================================
--- a/version.py
+++ b/version.py
@@ -24,5 +24,5 @@
     ]
 
 bzr_plugin_version = (2, 2, 0, 'final', 0)
-bzr_minimum_version = (2, 4, 0)
+bzr_minimum_version = (2, 5, 0)
 bzr_maximum_version = None