Package: celery / 4.2.1-5

Metadata

Package Version Patches format
celery 4.2.1-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
lsb init.patch | (download)

extra/generic-init.d/celerybeat | 12 12 + 0 - 0 !
extra/generic-init.d/celeryd | 11 11 + 0 - 0 !
2 files changed, 23 insertions(+)

 lsb compliant headers, status actions and enabled variable

 Upstream ships it's own init scripts but they lack some LSB header and
 the (optional) "status" action. This patch fixes this and also adds a
 variable called ENABLED in /etc/default/celeryd.
privacy.patch | (download)

docs/_templates/sidebardonations.html | 11 0 + 11 - 0 !
1 file changed, 11 deletions(-)

 remove external assets from documentation.

 Upstream includes a PayPal donation form in it's sphinx templates for which the
 submit button used an external image and which was replaced by a simple
 <button/> element. Also a gittip button is loaded inside an <iframe/> which is
 removed. The logo image was loaded from the project website and is replaced
 with the local image file.
0007 Set shell in su invocation.patch | (download)

extra/generic-init.d/celerybeat | 2 1 + 1 - 0 !
extra/generic-init.d/celeryd | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 set shell in su invocation

See Bug#824786: celeryd: Initscript doesn't start daemon,
http://bugs.debian.org/824786

0004 Disable intershpinx mapping for now.patch | (download)

docs/conf.py | 4 1 + 3 - 0 !
1 file changed, 1 insertion(+), 3 deletions(-)

 disable intershpinx mapping for now.

The best way to fix network requests when building the documentation would be to
patch INTERSPHINX_MAPPING in sphinx_celery.conf in src:sphinx-celery.

0005 Disable pytest 3.3 log capturing to avoid changing l.patch | (download)

setup.cfg | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 disable pytest (>=3.3) log capturing to avoid changing log handlers
 (Closes: #892640).


0006 Remove upper version cap for pytest.patch | (download)

requirements/test.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 remove upper version cap for pytest.


0008 Python 3.7 compat issues 4852.patch | (download)

celery/backends/async.py | 299 0 + 299 - 0 !
celery/backends/asynchronous.py | 299 299 + 0 - 0 !
celery/backends/redis.py | 7 4 + 3 - 0 !
celery/backends/rpc.py | 2 1 + 1 - 0 !
docs/internals/reference/celery.backends.async.rst | 13 0 + 13 - 0 !
docs/internals/reference/celery.backends.asynchronous.rst | 13 13 + 0 - 0 !
t/unit/backends/test_redis.py | 4 2 + 2 - 0 !
7 files changed, 319 insertions(+), 318 deletions(-)

 python 3.7 compat issues (#4852)

* renamed banckend.async to asynchronous

* adjust redis imports of async

* adjust imports of async

* import style adjust

* renamed doc from async to asynchronous

* renamed doc contents from async to asynchronous

0008 Added compatibility with python 3.7 4902.patch | (download)

celery/app/routes.py | 8 7 + 1 - 0 !
t/unit/app/test_routes.py | 5 5 + 0 - 0 !
2 files changed, 12 insertions(+), 1 deletion(-)

 added compatibility with python 3.7 (#4902)


py37 skip tests.diff | (download)

t/unit/worker/test_loops.py | 4 3 + 1 - 0 !
1 file changed, 3 insertions(+), 1 deletion(-)

 skip some tests that fail with py 3.7

Bug: https://github.com/celery/celery/issues/4913

0010 Relax version requirements on billiard.patch | (download)

requirements/default.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 relax version requirements on billiard.


0011 Fix for a function renamed in pytest 4.patch | (download)

celery/contrib/pytest.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix for a function renamed in pytest 4.


0012 Fix passing options to pytest.patch | (download)

setup.py | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 fix passing options to pytest.