Package: cowpatty / 4.8-2

Metadata

Package Version Patches format
cowpatty 4.8-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
kali overflow.patch | (download)

cowpatty.c | 273 195 + 78 - 0 !
cowpatty.h | 6 5 + 1 - 0 !
2 files changed, 200 insertions(+), 79 deletions(-)

 patch from kali linux to fix overflow
fix makefile.patch | (download)

Makefile | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix make clean target
makefile flags.patch | (download)

Makefile | 16 7 + 9 - 0 !
1 file changed, 7 insertions(+), 9 deletions(-)

 fix cppflags, cflags and ldflags usage
makefile parallel.patch | (download)

Makefile | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix target dependency for parallel build

 As detected on Debian[0], build with more than 4 jobs always fails
 because the dependencies of the targets cowpatty and genpmk are not
 well defined, this patch accomplish that and fixes the build on machines
 with more than 4 threads.

 [0]https://tests.reproducible-builds.org/debian/rbuild/buster/amd64/cowpatty_4.8-1.rbuild.log.gz