Package: crmsh / 4.1.0-3

Metadata

Package Version Patches format
crmsh 4.1.0-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0003 Add remote resource to local cache.patch | (download)

doc/website-v1/img/fork-me-on-github.png | 65 65 + 0 - 0 !
1 file changed, 65 insertions(+)

 add remote resource to local cache

 - Added the fork-me-on-github.png image so that 
   privacy-breach-generic could be resolved due to the 
   use of said image as a remote resource

0004 Fix privacy breach generic caused by footer template.patch | (download)

doc/website-v1/crm.conf | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix privacy-breach-generic caused by footer template

 - An image fetched from githubuserconent needs to be 
   replaced with a local cache to avoid the 
   aforementioned lintian informational warning

0005 Fix privacy breach generic caused by atom xml templa.patch | (download)

doc/website-v1/make-news.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix privacy-breach-generic caused by atom xml template

 - Modifies the atom xml template so as not to breach 
   privacy by using remote resources.

0006 Fix privacy breach generic caused by youtube iframe.patch | (download)

doc/website-v1/news/2015-05-13-release-2_1_4.adoc | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix privacy-breach-generic caused by youtube iframe

 - Modified 2015-05-13-releaswe-2_1_4.adoc so as not to 
   embed the youtube video

0007 pygmentize lexer.patch | (download)

doc/website-v1/history-guide.adoc | 16 8 + 8 - 0 !
1 file changed, 8 insertions(+), 8 deletions(-)

 patch to avoid using the custom lexer
 This patch makes some changes to the crmsh doc build so it doesn't use
 the included custom lexer.
0010 Fix package management.patch | (download)

utils/crm_init.py | 4 2 + 2 - 0 !
utils/crm_script.py | 4 2 + 2 - 0 !
2 files changed, 4 insertions(+), 4 deletions(-)

 use dpkg and apt for package management
0011 Fix scripts init.patch | (download)

crmsh/corosync.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 make cluster init work on debian
0012 Fix crm history.patch | (download)

crmsh/config.py | 2 1 + 1 - 0 !
crmsh/history.py | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 fix detection of cluster events
 hb_report looks at /var/log/messages for cluster events by default.
 On Debian systems this file only contains kernel messages so we use
 /var/log/syslog instead.
 .
 Since the pacemaker looging moved to /var/log/pacemaker.log rather
 than syslog, only this new file contains info on transitions so
 use it instead of standard syslog messaging.
0013 Fix cluster bootstrap.patch | (download)

crmsh/bootstrap.py | 28 14 + 14 - 0 !
crmsh/corosync.py | 5 4 + 1 - 0 !
2 files changed, 18 insertions(+), 15 deletions(-)

 fix cluster init on debian
 Update file paths and service names to work better on Debian.
0014 Fix cluster stop start.patch | (download)

crmsh/ui_cluster.py | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 fix crm cluster stop/start on debian
 Corosync remains running after 'crm cluster stop'.
 Don't rely on systemd service dependencies to stop it
 and also make it work with sysv init.
0015 Fix testsuite errors.patch | (download)

test/testcases/commit.exp | 20 18 + 2 - 0 !
test/testcases/confbasic.exp | 7 7 + 0 - 0 !
test/testcases/edit.exp | 6 6 + 0 - 0 !
test/testcases/ra.exp | 15 7 + 8 - 0 !
test/testcases/resource.exp | 20 14 + 6 - 0 !
test/testcases/scripts.exp | 6 3 + 3 - 0 !
test/testcases/shadow.exp | 4 2 + 2 - 0 !
test/unittests/test_parse.py | 16 8 + 8 - 0 !
8 files changed, 65 insertions(+), 29 deletions(-)

 fix testsuite
 Make sure testsuite output works with Pacemaker 2.
0016 Fix python2 calls.patch | (download)

doc/website-v1/Makefile | 15 8 + 7 - 0 !
doc/website-v1/make-news.py | 2 1 + 1 - 0 !
doc/website-v1/postprocess.py | 20 10 + 10 - 0 !
requirements.txt | 2 1 + 1 - 0 !
setup.py | 2 1 + 1 - 0 !
5 files changed, 21 insertions(+), 20 deletions(-)

 build using only python 3
0017 Fix spelling.patch | (download)

doc/crm.8.adoc | 2 1 + 1 - 0 !
doc/website-v1/man-1.2.adoc | 2 1 + 1 - 0 !
doc/website-v1/man-2.0.adoc | 2 1 + 1 - 0 !
doc/website-v1/man-3.adoc | 2 1 + 1 - 0 !
4 files changed, 4 insertions(+), 4 deletions(-)

 fix spelling reported by lintian
0018 Fix yaml loader.patch | (download)

crmsh/scripts.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix yaml warning for unsafe loader
 unittests.test_scripts.test_load_legacy ... /usr/lib/python3/dist-packages/crmsh/scripts.py:431: YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated, as the default Loader is unsafe. Please read https://msg.pyyaml.org/load for full details.
  data = yaml.load(f)