Package: dicompyler / 0.4.2.0+git20200106.2643e0e-1

Metadata

Package Version Patches format
dicompyler 0.4.2.0+git20200106.2643e0e-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
do_not_download_distribute.patch | (download)

distribute_setup.py | 17 9 + 8 - 0 !
1 file changed, 9 insertions(+), 8 deletions(-)

 do not download setuptools
wxpy30.patch | (download)

dicompyler/wxmpl.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 apply wx-migration-tool which was developed by olly betts
 http://anonscm.debian.org/cgit/collab-maint/wx-migration-tools.git


wxpy30 more.patch | (download)

dicompyler/baseplugins/anonymize.py | 6 4 + 2 - 0 !
dicompyler/preferences.py | 4 3 + 1 - 0 !
2 files changed, 7 insertions(+), 3 deletions(-)

 further patches not applied by wx-migration-tool from
 http://anonscm.debian.org/cgit/collab-maint/wx-migration-tools.git


092017A_fixpubsub.patch | (download)

dicompyler/baseplugins/2dview.py | 2 1 + 1 - 0 !
dicompyler/baseplugins/anonymize.py | 5 2 + 3 - 0 !
dicompyler/preferences.py | 5 2 + 3 - 0 !
3 files changed, 5 insertions(+), 7 deletions(-)

 wx.lib.pubsub fix according to https://wxpython.org/phoenix/docs/html/wx.lib.pubsub.setuparg1.html


092017E_newwxmpl.patch | (download)

dicompyler/wxmpl.py | 34 17 + 17 - 0 !
1 file changed, 17 insertions(+), 17 deletions(-)

 wxmpl file was outdated, so it was updated to github.com/noaa-orr-erd/wxmpl version "2.1.0dev1" including patch matplotlib.1069221.n5.nabble.com/wxmpl-patch-td34955.html