Package: djangorestframework-gis / 0.16-1

Metadata

Package Version Patches format
djangorestframework-gis 0.16-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
spatialite.patch | (download)

tests/settings.py | 14 8 + 6 - 0 !
1 file changed, 8 insertions(+), 6 deletions(-)

 use spatialite backend for tests.

 Some of the upstream tests are designed to test features only supported on a
 PostGIS enable database. To make the tests run with an embedded spatialite
 database, those tests are skipped if the database connection ist not done using
 the PostGIS driver.
 See the following URL for a compatibility matrix:
 https://docs.djangoproject.com/en/1.7/ref/contrib/gis/db-api/#compatibility-tables
0002 Do not import local settings for tests.patch | (download)

tests/settings.py | 6 0 + 6 - 0 !
1 file changed, 6 deletions(-)

 do not import local settings for tests.


0003 Add TEMPLATES setting for Django 1.8.patch | (download)

tests/settings.py | 19 19 + 0 - 0 !
1 file changed, 19 insertions(+)

 add templates setting for django 1.8+.


0004 Use io.open when reading UTF 8 encoded file for Pyth.patch | (download)

setup.py | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 use io.open when reading utf-8 encoded file for python2
 compatibility.


0005 Skip tests that either depend on Django3 or PostGIS.patch | (download)

tests/django_restframework_gis_tests/test_filters.py | 14 6 + 8 - 0 !
tests/django_restframework_gis_tests/tests.py | 7 7 + 0 - 0 !
2 files changed, 13 insertions(+), 8 deletions(-)

 skip tests that either depend on django3 or postgis.