Package: dokuwiki / 0.0.20180422.a-2.1

Metadata

Package Version Patches format
dokuwiki 0.0.20180422.a-2.1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
use_packaged_simplepie.diff | (download)

inc/load.php | 2 1 + 1 - 0 !
vendor/composer/autoload_namespaces.php | 2 1 + 1 - 0 !
vendor/composer/autoload_static.php | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 use packaged version of simplepie instead of an embedded one
use_packaged_php geshi_SA32559.diff | (download)

inc/parserutils.php | 2 1 + 1 - 0 !
vendor/composer/autoload_classmap.php | 2 1 + 1 - 0 !
vendor/composer/autoload_static.php | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 use packaged version of geshi instead of an embedded one
Bug-Debian: http://bugs.debian.org/513869
use_packaged_php seclib.diff | (download)

vendor/composer/autoload_files.php | 2 1 + 1 - 0 !
vendor/composer/autoload_psr4.php | 2 1 + 1 - 0 !
vendor/composer/autoload_static.php | 4 2 + 2 - 0 !
3 files changed, 4 insertions(+), 4 deletions(-)

 use the packaged version of php-seclib instead of the embedded one
debianize.diff | (download)

conf/dokuwiki.php | 6 3 + 3 - 0 !
lib/tpl/dokuwiki/tpl_footer.php | 2 2 + 0 - 0 !
2 files changed, 5 insertions(+), 3 deletions(-)

 add a custom look and configure properly for debian use
 * Debian look: add “Debian” to the default wiki title, and add a Debian info
   button.
 * Configuration: change the data directory and disable update check which is
   not relevant.
 * Installation script: add the custom configuration file checksum.
use_packaged_jquery.diff | (download)

lib/exe/jquery.php | 4 2 + 2 - 0 !
lib/exe/js.php | 4 2 + 2 - 0 !
2 files changed, 4 insertions(+), 4 deletions(-)

 use packaged version of jquery instead of an embedded one
use_packaged_php random compat.diff | (download)

vendor/composer/autoload_files.php | 2 1 + 1 - 0 !
vendor/composer/autoload_static.php | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 use the packaged version of php-random-compat instead of the embedded one