Package: eclipse / 3.8.1-10

servlet3.1-compatibility.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Description: Fixes the compatibility with the Servlet API 3.1
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: not-needed
--- a/eclipse/plugins/org.eclipse.equinox.http.servlet/META-INF/MANIFEST.MF
+++ b/eclipse/plugins/org.eclipse.equinox.http.servlet/META-INF/MANIFEST.MF
@@ -9,10 +9,10 @@
 Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,
  J2SE-1.3
 Export-Package: org.eclipse.equinox.http.servlet;version="1.1.0"
-Import-Package: javax.servlet;version="[2.3.0,3.1)",
+Import-Package: javax.servlet;version="[2.3.0,4.0)",
  javax.servlet.annotation;version="2.6.0";resolution:=optional,
  javax.servlet.descriptor;version="2.6.0";resolution:=optional, 
- javax.servlet.http;version="[2.3,3.1)",
+ javax.servlet.http;version="[2.3,4.0)",
  org.osgi.framework;version="1.3.0",
  org.osgi.service.http;version="[1.2,1.3)"
 Comment-Header: Both Eclipse-LazyStart and Bundle-ActivationPolicy are specified for compatibility with 3.2
--- a/eclipse/plugins/org.eclipse.equinox.jsp.jasper/META-INF/MANIFEST.MF
+++ b/eclipse/plugins/org.eclipse.equinox.jsp.jasper/META-INF/MANIFEST.MF
@@ -6,12 +6,12 @@
 Bundle-SymbolicName: org.eclipse.equinox.jsp.jasper
 Bundle-Version: 1.0.400.qualifier
 Bundle-Activator: org.eclipse.equinox.internal.jsp.jasper.Activator
-Import-Package: javax.servlet;version="[2.4, 3.1)",
+Import-Package: javax.servlet;version="[2.4, 4.0)",
  javax.servlet.annotation;version="2.6";resolution:=optional,
  javax.servlet.descriptor;version="2.6";resolution:=optional,
- javax.servlet.http;version="[2.4, 3.1)",
- javax.servlet.jsp;version="[2.0, 2.3)",
- org.apache.jasper.servlet;version="[0, 6)",
+ javax.servlet.http;version="[2.4, 4.0)",
+ javax.servlet.jsp;version="[2.0, 2.3]",
+ org.apache.jasper.servlet;version="[0, 9)";resolution:=optional,
  org.osgi.framework;version="1.3.0",
  org.osgi.service.http;version="1.2.0",
  org.osgi.service.packageadmin;version="1.2.0",