Package: emscripten / 2.0.13~dfsg-1~rc1

Metadata

Package Version Patches format
emscripten 2.0.13~dfsg-1~rc1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
1001_python3_shebang.patch | (download)

emranlib.py | 2 1 + 1 - 0 !
system/bin/sdl-config | 2 1 + 1 - 0 !
system/bin/sdl2-config | 2 1 + 1 - 0 !
system/lib/update_compiler_rt.py | 2 1 + 1 - 0 !
system/lib/update_libcxx.py | 2 1 + 1 - 0 !
system/lib/update_libcxxabi.py | 2 1 + 1 - 0 !
tests/fuzz/creduce_tester.py | 2 1 + 1 - 0 !
tests/fuzz/csmith_driver.py | 2 1 + 1 - 0 !
tests/gen_large_switchcase.py | 2 1 + 1 - 0 !
tests/gen_many_js_functions.py | 2 1 + 1 - 0 !
third_party/websockify/run | 2 1 + 1 - 0 !
third_party/websockify/websockify/websocket.py | 2 1 + 1 - 0 !
third_party/websockify/websockify/websocketproxy.py | 2 1 + 1 - 0 !
tools/ctor_evaller.py | 2 1 + 1 - 0 !
tools/emprofile.py | 2 1 + 1 - 0 !
tools/file_packager.py | 2 1 + 1 - 0 !
tools/scons/site_scons/site_tools/emscripten/__init__.py | 2 1 + 1 - 0 !
tools/scons/site_scons/site_tools/emscripten/emscripten.py | 2 1 + 1 - 0 !
tools/simde_update.py | 2 1 + 1 - 0 !
19 files changed, 19 insertions(+), 19 deletions(-)

 consistently use python3 in shebang
1002_find_syntax.patch | (download)

tests/third_party/freealut/Makefile.am | 2 1 + 1 - 0 !
tests/third_party/freealut/Makefile.in | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 avoid obsolete gnu-specific find syntax
 The syntax "find -perm +222" was a GNU extension
 which was dropped since findutils 4.5.11.
1004_acorn_ecmaVersion.patch | (download)

tools/acorn-optimizer.js | 4 2 + 2 - 0 !
tools/building.py | 2 1 + 1 - 0 !
2 files changed, 3 insertions(+), 3 deletions(-)

 use latest ecmaversion
 Acorn 8.0.0 introduced ecmaScript 'latest'
 to be as relaxed as possible,
 and at the same time made defining ecmaScript mandatory.
 .
 This patch declares ecmaScript at both places it is used
 to avoid warning when upgrading to acon 8,
 and while at it switches to this new 'latest'.
 .
 Also, corresponding closure-compiler option is updated.
 .
 See also <https://github.com/emscripten-core/emscripten/issues/11303#issuecomment-698673424>
1005_reproducible_build.patch | (download)

tools/create_dom_pk_codes.py | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 make the build reproducible
1007_tests_support_skip_closure compiler.patch | (download)

tests/runner.py | 13 13 + 0 - 0 !
tests/test_core.py | 29 16 + 13 - 0 !
tests/test_other.py | 87 56 + 31 - 0 !
3 files changed, 85 insertions(+), 44 deletions(-)

---
1008_tests_no_hardcode_tool_name.patch | (download)

tests/test_other.py | 10 5 + 5 - 0 !
1 file changed, 5 insertions(+), 5 deletions(-)

---
2001_explicit_shebang.patch | (download)

src/compiler.js | 2 1 + 1 - 0 !
system/lib/build_cxx_natively.sh | 2 2 + 0 - 0 !
tests/fuzz/test.sh | 2 2 + 0 - 0 !
tests/fuzz/testpp.sh | 2 2 + 0 - 0 !
third_party/uglify-js/bin/uglifyjs | 2 1 + 1 - 0 !
third_party/uglify-js/test/beautify.js | 2 1 + 1 - 0 !
third_party/uglify-js/test/testparser.js | 2 1 + 1 - 0 !
third_party/uglify-js/tmp/test.js | 2 1 + 1 - 0 !
third_party/websockify/other/js/websockify.js | 2 1 + 1 - 0 !
third_party/websockify/other/launch.sh | 2 1 + 1 - 0 !
third_party/websockify/other/websockify.rb | 2 1 + 1 - 0 !
third_party/websockify/other/wswrap | 2 1 + 1 - 0 !
tools/js-optimizer.js | 2 1 + 1 - 0 !
tools/preprocessor.js | 2 1 + 1 - 0 !
tools/source-maps/sourcemap2json.js | 2 1 + 1 - 0 !
tools/source-maps/sourcemapper.js | 2 1 + 1 - 0 !
16 files changed, 19 insertions(+), 13 deletions(-)

 explicit call executable in shebang
 Omit python3: Handled by packaging routines
2002_avoid_git.patch | (download)

tools/install.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 avoid calling git during build
2003_avoid_install_packaging.patch | (download)

tools/install.py | 40 38 + 2 - 0 !
1 file changed, 38 insertions(+), 2 deletions(-)

 avoid install packaging files
 Also avoid third-party files unused at runtime,
 confusing packaging routines.
2004_privacy.patch | (download)

README.md | 4 0 + 4 - 0 !
tools/toolchain_profiler.results_template.html | 2 1 + 1 - 0 !
2 files changed, 1 insertion(+), 5 deletions(-)

 avoid privacy leaks in html code
2005_older_llvm.patch | (download)

tools/shared.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 relax to expect older llvm
 Upstream expected version 12.0 is not yet in Debian.
2006_call_emscripten_in_PATH.patch | (download)

tools/shared.py | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 call emscripten scripts in path when called from emscripten
2007_es_check.patch | (download)

tests/runner.py | 8 3 + 5 - 0 !
1 file changed, 3 insertions(+), 5 deletions(-)

 use eslint instead of es-check missing in debian
2008_minify_html.patch | (download)

emcc.py | 29 3 + 26 - 0 !
1 file changed, 3 insertions(+), 26 deletions(-)

 use htmlmin instead of html-minifier-terser missing in debian
2009_closure compiler.patch | (download)

tools/building.py | 15 8 + 7 - 0 !
1 file changed, 8 insertions(+), 7 deletions(-)

 use system-shared closure-compiler
 Avoid fetching closure-compiler with npm.
 Simply expect it to be available in PATH.
 .
 Also, skip checking option --version
 which hangs with old Debian release.
2010_avoid_npm.patch | (download)

Makefile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 avoid using npm during build
2011_system_shared_tools.patch | (download)

tools/config.py | 3 3 + 0 - 0 !
tools/settings_template.py | 2 1 + 1 - 0 !
2 files changed, 4 insertions(+), 1 deletion(-)

 detect and use system shared binaryen