Package: fftw / 2.1.5-4.2

perl-cwd-in-inc.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Description: require() sripts with ./
 After cwd was removed from perl's @INC (CVE-2016-1238),
 bfnnconv.pl doesn't find its "subscripts" anymore.
 require them with "./" prefixed.
Origin: vendor
Bug-Debian: https://bugs.debian.org/837055
Forwarded: no
Author: gregor herrmann <gregoa@debian.org>
Last-Update: 2016-09-18

--- a/FAQ/bfnnconv.pl
+++ b/FAQ/bfnnconv.pl
@@ -61,7 +61,7 @@
 
 open(U,">$prefix.xrefdb-new");
 
-for $x (@outputs) { require("m-$x.pl"); }
+for $x (@outputs) { require("./m-$x.pl"); }
 
 &call('init');