Package: filemanager-actions / 3.4-2

cross-pkg-config.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
From: Carlos Maddela <e7appew@gmail.com>
Date: Sat, 1 Dec 2018 03:02:44 +1100
Subject: Use cross-compilation-safe pkg-config macro.

Description: Use cross-compilation-safe pkg-config macro.
Author: Carlos Maddela <e7appew@gmail.com>
Bug-Debian: https://bugs.debian.org/884798
Forwarded: https://gitlab.gnome.org/GNOME/filemanager-actions/merge_requests/1
Last-Update: 2018-12-04
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---
 configure.ac | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/configure.ac b/configure.ac
index e4bf029..78af9b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,10 +63,7 @@ FMA_MAINTAINER_CHECK_MODE
 AM_PROG_LIBTOOL
 
 # we are using pkgconfig for all development libraries we need
-AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
-if test "${PKG_CONFIG}" = "no"; then
-	AC_MSG_ERROR([You need to install pkg-config])
-fi
+PKG_PROG_PKG_CONFIG
 
 # required versions of tools and libraries
 source ${0%/*}/fma_required_versions