Package: fis-gtm / 6.2-000-1

Metadata

Package Version Patches format
fis-gtm 6.2-000-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
upstream_fix_speeling_errors | (download)

sr_port/dse_shift.c | 2 1 + 1 - 0 !
sr_port/rsel.mpt | 4 2 + 2 - 0 !
sr_port/xcmd.mpt | 2 1 + 1 - 0 !
3 files changed, 4 insertions(+), 4 deletions(-)

 upstream sources contain spelling errors in one message for the
  DSE utility program. This is now fixed to avoid the lintian warning
  spelling-error-in-binary. MUMPS sources are now compiled with -embed_source
  which embeds the source in the object file. Comments in two MUMPS routines
  contained spelling errors. These are now fixed to avoid the lintian warning
  spelling-error-in-binary.
upstream_build_all_encryption_libs | (download)

CMakeLists.txt | 57 45 + 12 - 0 !
1 file changed, 45 insertions(+), 12 deletions(-)

 the upstream v6.2-000 cmakelists.txt file built only one of three
  possible encryption plugin libraries. This meant that the debian fis-gtm
  package was missing a core piece of the distributed binaries. Upstream will
  apply this change to the next release after internal review.
  UPDATE: Build, but do not install the reference encryption plugins due to
  licensing conflicts between the AGPL and the OpenSSL license. Reference
  plugins are built simply to ensure that they could compile on the target
  system provided the correct libraries are installed.