Package: freebsd-libs / 10.3~svn296373-10

libbsd_nlist.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

This patch is not required for build, because freebsd-glue provides
<nlist.h>, however it is still required when using kvm.h in an external
package. See #729536.

--- a/lib/libkvm/kvm.h
+++ b/lib/libkvm/kvm.h
@@ -36,7 +36,7 @@
 #include <sys/cdefs.h>
 #include <sys/types.h>
 #include <stdint.h>		/* uint64_t */
-#include <nlist.h>
+#include <bsd/nlist.h>
 
 /* Default version symbol. */
 #define	VRS_SYM		"_version"