Package: fso-audiod / 0.12.0-3

Metadata

Package Version Patches format
fso-audiod 0.12.0-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix pkglibdir.patch | (download)

configure.ac | 10 8 + 2 - 0 !
1 file changed, 8 insertions(+), 2 deletions(-)

 search modules in multiarch path
 The modules are installed correctly into the multiarch
 path, but the code doesn't look for them in these
 directories. This patch changes the module search path
 to the correct multiarch path.
fix pkg alsa.patch | (download)

src/plugins/gsmvoice_alsa_forwarder/Makefile.am | 1 1 + 0 - 0 !
src/plugins/manager/Makefile.am | 1 1 + 0 - 0 !
src/plugins/router_alsa/Makefile.am | 1 1 + 0 - 0 !
src/plugins/sessionpolicy_default/Makefile.am | 1 1 + 0 - 0 !
src/plugins/streamcontrol_alsa/Makefile.am | 1 1 + 0 - 0 !
src/plugins/system_integration/Makefile.am | 1 1 + 0 - 0 !
6 files changed, 6 insertions(+)

---
update gee dependency.patch | (download)

configure.ac | 2 1 + 1 - 0 !
src/lib/Makefile.am | 2 1 + 1 - 0 !
src/plugins/gsmvoice_alsa_cmtspeechdata/Makefile.am | 2 1 + 1 - 0 !
src/plugins/gsmvoice_alsa_forwarder/Makefile.am | 2 1 + 1 - 0 !
src/plugins/manager/Makefile.am | 2 1 + 1 - 0 !
src/plugins/router_alsa/Makefile.am | 2 1 + 1 - 0 !
src/plugins/sessionpolicy_default/Makefile.am | 2 1 + 1 - 0 !
src/plugins/streamcontrol_alsa/Makefile.am | 2 1 + 1 - 0 !
src/plugins/system_integration/Makefile.am | 2 1 + 1 - 0 !
9 files changed, 9 insertions(+), 9 deletions(-)

 update libgee dependency to libgee-0.8-dev
 Debian no longer support the apparently older libgee-1.0.
 The code is fine with the newer libgee-0.8 package, but
 it must be referenced correctly. Upstream git already
 contains a similar fix, so no forwarding is needed.
use new thread api.patch | (download)

src/plugins/gsmvoice_alsa_cmtspeechdata/Makefile.am | 1 1 + 0 - 0 !
src/plugins/gsmvoice_alsa_cmtspeechdata/cmthandler.vala | 8 4 + 4 - 0 !
2 files changed, 5 insertions(+), 4 deletions(-)

 use newer thread api
 The old Thread API does not work with the vala release
 currently available in Debian. This patch changes the
 thread handling to use the newer Thread API resulting
 in a requirement on GLib 2.32.
fix dbus permissions.patch | (download)

data/fsoaudiod.conf | 9 3 + 6 - 0 !
1 file changed, 3 insertions(+), 6 deletions(-)

 fix security problem in dbus configuration
 Old configuration allows every local user to send arbitrary D-Bus
 messages to the path /org/freesmartphone/Framework on *any* D-Bus
 system service (rough HTTP analogy: send a POST to
 http://server/org/freesmartphone/Framework on any server).
Bug-CVE: https://security-tracker.debian.org/tracker/CVE-2014-8156


ofono support.patch | (download)

conf/nokia_n900/fsoaudiod.conf | 5 4 + 1 - 0 !
src/plugins/gsmvoice_alsa_cmtspeechdata/Makefile.am | 1 1 + 0 - 0 !
src/plugins/gsmvoice_alsa_cmtspeechdata/ofono.vala | 25 25 + 0 - 0 !
src/plugins/gsmvoice_alsa_cmtspeechdata/plugin.vala | 21 18 + 3 - 0 !
4 files changed, 48 insertions(+), 4 deletions(-)

 add support for using the cmtspeechdata plugin with ofono
 With this patch the FSO audio daemon can be used in
 conjunction with ofono instead of the FSO gsm daemon.