Package: ganv / 1.4.2~dfsg0-2

Metadata

Package Version Patches format
ganv 1.4.2~dfsg0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
1001 dont_run_ldconfig.patch | (download)

wscript | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 don't run ldconfig after calling the install target
 and save a bit of time.
noansi.patch | (download)

waflib/extras/autowaf.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 don't build with -ansi
 -ansi is for C++ equivalent to -std=c++98
 .
 sigc++-2.0 uses C++11 features in its headers, resulting in
 compile errors when trying to use these headers in C++98 mode.
 .
 Removing -ansi fixes the bug, depending on upstream policy
 building with -std=c++11 (or -std=c++14) instead of -ansi
 might be preferred by upstream with gcc versions that
 support these standards (untested).