Package: gargoyle-free / 2011.1-2

Metadata

Package Version Patches format
gargoyle-free 2011.1-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
dfsg_disable_hugo.patch | (download)

terps/Jamfile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable non-free hugo interpreter
dfsg_disable_alan2.patch | (download)

terps/Jamfile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable non-free alan2 interpreter
dfsg_replace_luximono_font.patch | (download)

Jamrules | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 replace the non-free luximono font
 Gargoyle uses embedded fonts by default, and one of them is non-free.
 Upstream otherwise included a Debian patch to load fonts from the
 system, we now just have to turn that on :)
ignore_bundled_libraries.patch | (download)

Jamrules | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 don't build the (deleted) bundled libraries in the 'support' directory
desktop_menu_entry_crs.patch | (download)

garglk/gargoyle.desktop | 18 9 + 9 - 0 !
1 file changed, 9 insertions(+), 9 deletions(-)

 dos2unix
desktop_menu_entry.patch | (download)

garglk/gargoyle.desktop | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 rename executable 'gargoyle' -> 'gargoyle-free'
fhs_locate_private_binaries.patch | (download)

garglk/launchgtk.c | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 look for sub-binaries in /usr/lib/gargoyle/
  It might be better to link the binaries with
  rpath=/usr/lib/gargoyle, since the binaries may be used
  independently; however this may conflict with existing packages,
  such as 'frotz', which would need to be divert'd.
  There are mixing feelings towards this approach on the list.
librt.patch | (download)

Jamrules | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 requires -lrt
  Well, it has been a requirement for a while AFAICS, so my guess is
  that it was previously gotten indirectly through pkg-config --libs,
  but not anymore.