Package: gfarm / 2.7.11+dfsg-1.1

Metadata

Package Version Patches format
gfarm 2.7.11+dfsg-1.1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_noneed_yacc_lex.patch | (download)

configure.ac | 8 0 + 8 - 0 !
1 file changed, 8 deletions(-)

 no need to check yacc&lex.


02_dont_go_doc.patch | (download)

Makefile.in | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 don't go 'doc' subdirectory.
03_libtool_clean_does_not_work_well.patch | (download)

makes/lib.mk | 3 1 + 2 - 0 !
1 file changed, 1 insertion(+), 2 deletions(-)

 libtool clean doesn't work well.
 Thus, we need this change. 
build hurd.patch | (download)

include/gfarm/gfarm_misc.h | 4 4 + 0 - 0 !
lib/libgfarm/gfarm/host.c | 4 4 + 0 - 0 !
server/gfmd/db_journal.c | 3 3 + 0 - 0 !
3 files changed, 11 insertions(+)

 workaround for no [maxhostnamelen, maxpathlen, path_max] definitions (on hurd-i386)


clean.patch | (download)

Makefile.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 assist cleanup; prevent removal of "makes/config.mk".


defaults.patch | (download)

gftool/config-gfarm/config-gfarm.postgresql | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 enable postgresql "data page checksums".


pg_ctl.patch | (download)

gftool/config-gfarm/config-gfarm.postgresql | 6 6 + 0 - 0 !
1 file changed, 6 insertions(+)

 detect version of postgresql using pg_conftool
 `config-gfarm` uses `pg_config` (provided by "libpq-dev" or by
 "postgresql-server-dev-X.Y") to detect version of PostgreSQL. This patch
 uses `pg_conftool` to remove dependency on above packages and make the
 following error non fatal:
    You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.