Package: gmerlin-avdecoder / 1.2.0~dfsg-5

Metadata

Package Version Patches format
gmerlin-avdecoder 1.2.0~dfsg-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix_dvdread_configure.patch | (download)

m4/check_funcs.m4 | 4 0 + 4 - 0 !
1 file changed, 4 deletions(-)

 fix dvdread detection
autoconf_removed_sources.patch | (download)

configure.ac | 7 0 + 7 - 0 !
lib/Makefile.am | 14 1 + 13 - 0 !
2 files changed, 1 insertion(+), 20 deletions(-)

 fix build-system due to removed upstream sources
system_gsm.patch | (download)

configure.ac | 12 12 + 0 - 0 !
lib/Makefile.am | 4 2 + 2 - 0 !
lib/audio_gsm.c | 6 5 + 1 - 0 !
3 files changed, 19 insertions(+), 3 deletions(-)

 use system libgsm
 use system's libgsm (+headers), since the version that ships with
 upstream is removed (for policy reasons) and the two are supposed to be
 compatible
gmerlin_versioned_depends.patch | (download)

configure.ac | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 gmerlin-avdec uses symbols only available in gmerlin>=1.2.0
 so the config-check should fail for older gmerlin-versions

fix_typos.patch | (download)

lib/demux_matroska.c | 2 1 + 1 - 0 !
lib/demux_nsv.c | 2 1 + 1 - 0 !
lib/in_rtsp.c | 2 1 + 1 - 0 !
lib/sdp.c | 2 1 + 1 - 0 !
plugins/i_avdec.c | 2 1 + 1 - 0 !
po/de.po | 8 4 + 4 - 0 !
po/gmerlin-avdecoder.pot | 8 4 + 4 - 0 !
7 files changed, 13 insertions(+), 13 deletions(-)

 fix various typos that made lintian complain
fix ftbfs libav9.patch | (download)

lib/audio_ffmpeg.c | 2 2 + 0 - 0 !
lib/demux_ffmpeg.c | 2 2 + 0 - 0 !
2 files changed, 4 insertions(+)

 fix ftbfs against libav 9
   * Unbreak compilation against libav 9
plugins ldflags.patch | (download)

configure.ac | 4 3 + 1 - 0 !
lib/Makefile.am | 2 1 + 1 - 0 !
2 files changed, 4 insertions(+), 2 deletions(-)

 propagate ldflags to plugins
libav10.patch | (download)

lib/audio_ffmpeg.c | 292 146 + 146 - 0 !
lib/demux_ffmpeg.c | 413 206 + 207 - 0 !
lib/video_ffmpeg.c | 451 223 + 228 - 0 !
3 files changed, 575 insertions(+), 581 deletions(-)

 libav10 compatibility
 package fails to build from source against libav 10 (currently packaged in
 experimental). This bug will become release-critical at some point when the
 libav10 transition starts.
 This patch renames CODEC_* constants to AV_CODEC_*, and CodecID to AVCodecID