Package: gmerlin / 1.2.0~dfsg+1-4

Metadata

Package Version Patches format
gmerlin 1.2.0~dfsg+1-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
desktop_files.patch | (download)

apps/recorder/gmerlin-recorder.desktop | 3 1 + 2 - 0 !
apps/transcoder/gmerlin-transcoder.desktop | 3 1 + 2 - 0 !
apps/visualizer/gmerlin-visualizer.desktop | 3 1 + 2 - 0 !
3 files changed, 3 insertions(+), 6 deletions(-)

 update desktop files as per freedesktop.org's spec.
 Remove 'Encoding' keys since they are deprecated.
 Consistently remove '.png' suffix in 'Icon' key
fix_manpages.patch | (download)

apps/cmdlineplayer/gmerlin_play.1 | 50 25 + 25 - 0 !
apps/cmdlinerecorder/gmerlin-record.1 | 212 106 + 106 - 0 !
apps/player/gmerlin.1 | 10 5 + 5 - 0 !
apps/player/gmerlin_remote.1 | 56 28 + 28 - 0 !
apps/transcoder/gmerlin_transcoder.1 | 12 6 + 6 - 0 !
apps/transcoder/gmerlin_transcoder_remote.1 | 20 10 + 10 - 0 !
lib/cmdline.c | 2 1 + 1 - 0 !
7 files changed, 181 insertions(+), 181 deletions(-)

 improve the manpages provide by upstream.
also make sure that generated manpages provide proper whois section
replace_bg_sem_h.patch | (download)

include/gmerlin/bg_sem.h | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 provide policy-compliant version of bg_sem.h
Since the upstream version includes BSD-4-clause'd licensed code, it cannot 
be distributed with debian; since the file is really only needed if no
posix semaphores are available, we just use these
fix_zeroplugins.patch | (download)

lib/pluginregistry.c | 21 13 + 8 - 0 !
1 file changed, 13 insertions(+), 8 deletions(-)

 prevent segfaults if no plugins can be found

gmerlin_visualizer_slave.patch | (download)

lib/Makefile.am | 4 3 + 1 - 0 !
lib/visualize.c | 11 8 + 3 - 0 !
2 files changed, 11 insertions(+), 4 deletions(-)

 move gmerlin_visualizer_slave into /usr/lib/gmerlin/bin
as "this program is not to be started from the cmdline" but rather directly from
libgmerlin (which of course has to be aware of the changed position)

fix_typos.patch | (download)

apps/kbd/kbd_config.c | 2 1 + 1 - 0 !
lib/lcdproc.c | 2 1 + 1 - 0 !
plugins/videofilters/fv_tctweak.c | 2 1 + 1 - 0 !
po/de.po | 4 2 + 2 - 0 !
po/gmerlin.pot | 4 2 + 2 - 0 !
5 files changed, 7 insertions(+), 7 deletions(-)

 fix various spelling errors reported by lintian

binutils_gold.patch | (download)

apps/alsamixer/Makefile.am | 2 1 + 1 - 0 !
apps/kbd/Makefile.am | 2 1 + 1 - 0 !
apps/player/Makefile.am | 2 1 + 1 - 0 !
apps/plugincfg/Makefile.am | 3 2 + 1 - 0 !
apps/recorder/Makefile.am | 3 2 + 1 - 0 !
apps/transcoder/Makefile.am | 3 2 + 1 - 0 !
apps/visualizer/Makefile.am | 2 1 + 1 - 0 !
lib/Makefile.am | 2 1 + 1 - 0 !
tests/Makefile.am | 16 8 + 8 - 0 !
9 files changed, 19 insertions(+), 16 deletions(-)

 prevent ftbfs with newest toolchain.
 This also allows gmerlin to build on Ubuntu Natty.
strip_doc_out.patch | (download)

Makefile.am | 2 1 + 1 - 0 !
configure.ac | 2 0 + 2 - 0 !
2 files changed, 1 insertion(+), 3 deletions(-)

 don't generate documentation, it's been removed as it was licensed under
 GFDL-1.1 license, which is DFSG incompatible.
hardening_ldflags.patch | (download)

configure.ac | 5 3 + 2 - 0 !
1 file changed, 3 insertions(+), 2 deletions(-)

 propagate ldflags through configure
 for hardening to take effect, we need to ensure that LDFLAGS passed to
 configure, are actually used
fix_transcoder_track.patch | (download)

lib/transcoder_track.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fixed function definition of bg_transcoder_track_get_general_parameters
 both the function declaration and the use of the function don't have any
 arguments.
 the argument in the definition isn't used either, so we just remove it.