Package: gmime / 2.6.22+dfsg2-1


Package Version Patches format
gmime 2.6.22+dfsg2-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix_gmime sharp.pc_path.patch | (download)

mono/ | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)


we use the standard packaging locations for debian mono.

0002 Rename g_mime_decryption_result_ to g_mime_decrypt_r.patch | (download)

gmime/gmime-crypto-context.c | 16 14 + 2 - 0 !
1 file changed, 14 insertions(+), 2 deletions(-)

 rename g_mime_decryption_result_* to g_mime_decrypt_result_*

Two functions appear to have been misnamed in gmime-crypto-context.c:
g_mime_decryption_result_get_mdc and
g_mime_decryption_result_get_session_key.  They should have been named
with a prefix of g_mime_decrypt_, not g_mime_decryption_ :(

Correcting this is technically an ABI change, but i don't think it
matters: the wrong function names never ended up in any .h files, so i
don't think anyone could have reliably used them.  A search of all of
debian shows no uses outside of the declaration in gmime itself:

At any rate, i've retained the old/misnamed functions as an alias to
the correctly-named functions to technically keep the ABI intact,
while actually supporting the declared functionality.