Package: gnome-online-accounts / 3.4.2-2

Metadata

Package Version Patches format
gnome-online-accounts 3.4.2-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_git_fix_build.patch | (download)

src/goabackend/Makefile.am | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 fix build failure with ldflags="-wl,-z,defs"
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=674292
3.4.x CVE 2013 0240.patch | (download)

src/goabackend/goaoauth2provider.c | 6 6 + 0 - 0 !
src/goabackend/goaoauthprovider.c | 6 6 + 0 - 0 !
2 files changed, 12 insertions(+)

 [patch] cve-2013-0240: do not allow invalid ssl certificates

None of the branded providers (eg., Google, Facebook and Windows Live)
should ever have an invalid certificate; and in this version of GOA,
that's all we have. So set "ssl-strict" on the SoupSession object
being used by GoaWebView.