Package: goffice-0.8 / 0.8.17-7

Metadata

Package Version Patches format
goffice-0.8 0.8.17-7 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix pcre.patch | (download)

configure.in | 16 1 + 15 - 0 !
1 file changed, 1 insertion(+), 15 deletions(-)

 fixes ftbfs with libpcre3-1:8.31:

    checking for UTF-8 support in pcre... configure: error: The installed PCRE library is not configured for UTF-8 support.


gcc6.patch | (download)

goffice/utils/go-format.c | 16 8 + 8 - 0 !
1 file changed, 8 insertions(+), 8 deletions(-)

 fix ftbfs with gcc-6.


no gnome compile warnings.patch | (download)

configure.in | 4 0 + 4 - 0 !
1 file changed, 4 deletions(-)

 stop using gnome_compile_warnings
 It is deprecated by GNOME, no longer used in upstream 0.10,
 and the -Werror=format=2 caused a FTBFS with gcc 6.

 This fixes both #829926 and #831144.