Package: groestlcoin / 2.17.2~dfsg-1

Metadata

Package Version Patches format
groestlcoin 2.17.2~dfsg-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
1001_use_system_leveldb.patch | (download)

configure.ac | 25 22 + 3 - 0 !
src/dbwrapper.cpp | 4 4 + 0 - 0 !
2 files changed, 26 insertions(+), 3 deletions(-)

 use system libleveldb-dev instead of a bundled one.
 Patch derived from Debian litecoin package, extended to be
 autoconfigurable.
1002_use_system_secp256k1.patch | (download)

configure.ac | 49 48 + 1 - 0 !
src/Makefile.am | 14 11 + 3 - 0 !
src/Makefile.test.include | 2 2 + 0 - 0 !
3 files changed, 61 insertions(+), 4 deletions(-)

 build against system secp256k1 when available
1003_improve_manpage_generator.patch | (download)

contrib/devtools/gen-manpages.sh | 18 11 + 7 - 0 !
1 file changed, 11 insertions(+), 7 deletions(-)

 improve manpage generator script
 Improve the contrib tool gen-manpages.sh.
 .
  * Optionally pass version(s) as argument(s).
  * Fix bashism by avoiding array references.
  * Exit on error
  * Use temporary file for copyright info
2001_avoid_embedded_libs.patch | (download)

Makefile.am | 11 10 + 1 - 0 !
src/Makefile.am | 10 8 + 2 - 0 !
2 files changed, 18 insertions(+), 3 deletions(-)

 avoid embedded libraries
2002_avoid_network_tests.patch | (download)

src/qt/test/test_main.cpp | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 avoid tests requiring network access