Package: gtk+2.0 / 2.24.32-3

Make-gtk-2.24.31-compatible-with-the-changed-API-of-glib-.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
From: Dennis Schridde <devurandom@gmx.net>
Date: Sun, 18 Mar 2018 19:49:38 +0100
Subject: Make gtk+-2.24.31 compatible with the changed API of glib-2.54.3

glib-2.54.3 changed API, compared to glib-2.52.3 and gtk+-2.24.31's
 expectations.  This commit fixes the resulting issue in a backwards
 compatible way.

See-Also: https://bugs.gentoo.org/650536
Applied-upstream: 2.24.33, commit:88bb7ecc47f5cd4d9ca9d2a7a8e096fec0d2e867
---
 gtk/gtk.symbols | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gtk/gtk.symbols b/gtk/gtk.symbols
index 6d5d5b6..a264df8 100644
--- a/gtk/gtk.symbols
+++ b/gtk/gtk.symbols
@@ -2498,8 +2498,8 @@ gtk_input_dialog_new
 #endif
 #endif
 
-#if IN_HEADER(__gtk_marshal_MARSHAL_H__)
-#if IN_FILE(__gtk_marshal_MARSHAL_C__)
+#if IN_HEADER(__gtk_marshal_MARSHAL_H__) || IN_HEADER(__GTK_MARSHAL_MARSHAL_H__)
+#if IN_FILE(__gtk_marshal_MARSHAL_C__) || IN_FILE(__GTK_MARSHAL_MARSHAL_C__)
 #ifndef GTK_DISABLE_DEPRECATED
 gtk_marshal_BOOLEAN__POINTER
 gtk_marshal_BOOLEAN__POINTER_INT_INT