Package: guile-gnome-platform / 2.16.5-2

fixes/0005-Fix-configure-s-interpretation-of-disable-Werror.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
From: Andreas Rottmann <a.rottmann@gmx.at>
Date: Wed, 30 May 2012 22:54:51 +0200
Subject: Fix configure's interpretation of --disable-Werror

---
 configure.ac |    6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index 3c787c4..514019a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,8 +64,10 @@ you run guile. (Which is a pain.)])
 fi
 
 WARN_CFLAGS=-Wall
-AC_ARG_ENABLE([Werror], AC_HELP_STRING([--enable-Werror],[Stop the build on warnings]),
-        [WARN_CFLAGS="-Wall -Werror"], [])
+AC_ARG_ENABLE([Werror], AC_HELP_STRING([--enable-Werror],[Stop the build on warnings]))
+if test "$enable_Werror" = yes; then
+  WARN_CFLAGS="-Wall -Werror"
+fi
 AC_SUBST(WARN_CFLAGS)
 
 DISABLE_DEPRECATED=false