Package: guile-ssh / 0.11.3-2

Metadata

Package Version Patches format
guile-ssh 0.11.3-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0004 libguile ssh Fix building with libssh 0.8.patch | (download)

NEWS | 17 17 + 0 - 0 !
configure.ac | 7 7 + 0 - 0 !
libguile-ssh/Makefile.am | 7 6 + 1 - 0 !
3 files changed, 30 insertions(+), 1 deletion(-)

 [patch 04/14] libguile-ssh: fix building with libssh 0.8

The 'libguile-ssh' library would fail to build due to missing 'libssh_threads'
library that was removed libssh 0.8.  This patch fixes that.

Reported by lantw44 in
<https://github.com/artyom-poptsov/guile-ssh/issues/9>

* configure.ac: Add check for libssh 0.8
* libguile-ssh/Makefile.am: Don't use 'libssh_threads' library when building
  with libssh 0.8+.
* NEWS: Update.

0005 tests server.scm server set valid values Add fix for.patch | (download)

tests/server.scm | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch 05/14] tests/server.scm ("server-set!, valid values"): add fix
 for libssh 0.8


drop openssl ecdsa | (download)

tests/key.scm | 38 6 + 32 - 0 !
1 file changed, 6 insertions(+), 32 deletions(-)

---