Package: haskell-authenticate-oauth / 1.4.0.8-2

Metadata

Package Version Patches format
haskell-authenticate-oauth 1.4.0.8-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Update to use resourcet 1.0.patch | (download)

Web/Authenticate/OAuth.hs | 32 14 + 18 - 0 !
Web/Authenticate/OAuth/IO.hs | 6 3 + 3 - 0 !
authenticate-oauth.cabal | 2 1 + 1 - 0 !
3 files changed, 18 insertions(+), 22 deletions(-)

 [patch] update to use resourcet >= 1.0

resourcet-1.0 doesn't have the `MonadUnsafeIO` class anymore, but
authenticate-oauth seems to be abusing that anyway. I have instead opted
to use `MonadIO` in the cases where `MonadUnsafeIO` was used.

no blaze builder conduit.diff | (download)

authenticate-oauth.cabal | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

---