Package: hhsuite / 3.2.0-2

Metadata

Package Version Patches format
hhsuite 3.2.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
perlscript_uselib | (download)

scripts/addss.pl | 2 1 + 1 - 0 !
scripts/create_profile_from_hhm.pl | 2 1 + 1 - 0 !
scripts/create_profile_from_hmmer.pl | 2 1 + 1 - 0 !
scripts/hhmakemodel.pl | 2 1 + 1 - 0 !
scripts/multithread.pl | 2 1 + 1 - 0 !
scripts/pdb2fasta.pl | 2 1 + 1 - 0 !
scripts/pdbfilter.pl | 2 1 + 1 - 0 !
scripts/renumberpdb.pl | 2 1 + 1 - 0 !
scripts/splitfasta.pl | 2 1 + 1 - 0 !
9 files changed, 9 insertions(+), 9 deletions(-)

 perl script use lib
  * Set paths to hhsuite components for Perl scripts.
perl_interpreter | (download)

scripts/create_profile_from_hhm.pl | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 patch perl interpreter as required by polich 5.1
 Perl Script Magic - http://www.debian.org/doc/packaging-manuals/perl-policy/ch-programs.html#s-hash_bang
add_Makefile_in_data.patch | (download)

data/Makefile | 11 11 + 0 - 0 !
1 file changed, 11 insertions(+)

 add makefile to data


disable ffindex build.patch | (download)

CMakeLists.txt | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 do not try to build ffindex
drop fmemopen.h.patch | (download)

src/CMakeLists.txt | 3 0 + 3 - 0 !
src/cs/cstranslate_app.h | 1 0 + 1 - 0 !
src/hhfunc.cpp | 1 0 + 1 - 0 !
src/hhprefilter.cpp | 1 0 + 1 - 0 !
4 files changed, 6 deletions(-)

 drop include for fmemopen
 According to the comments in the included files, this wrapper is only required for MacOS X and BSD.
disable AVX SSE.patch | (download)

cmake/CheckSSEFeatures.cmake | 42 21 + 21 - 0 !
src/CMakeLists.txt | 18 9 + 9 - 0 !
2 files changed, 30 insertions(+), 30 deletions(-)

 do not use avx to build binaries 
python3 | (download)

scripts/a3m.py | 2 1 + 1 - 0 !
scripts/check_a3m.py | 2 1 + 1 - 0 !
scripts/cif2fasta.py | 2 1 + 1 - 0 !
scripts/ffindex.py | 2 1 + 1 - 0 !
scripts/get_a3m_size.py | 2 1 + 1 - 0 !
scripts/hh_reader.py | 2 1 + 1 - 0 !
scripts/hhmakemodel.py | 2 1 + 1 - 0 !
scripts/hhsuitedb.py | 2 1 + 1 - 0 !
scripts/pdbfilter.py | 2 1 + 1 - 0 !
9 files changed, 9 insertions(+), 9 deletions(-)

 scripts are already python3 compatible; mark them as so