Package: imposm / 2.6.0+ds-6

geos-capi-version.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Description: Disable failing geos_capi_version check.
 The minimum required GEOS version is in Debian.
Author: Bas Couwenberg <sebastic@debian.org>

--- a/imposm/geom.py
+++ b/imposm/geom.py
@@ -48,7 +48,10 @@ TOLERANCE_DEEGREES = 1e-8
 TOLERANCE_METERS = 1e-3
 
 # older versions had unhandled floating point execptions in .buffer(0)
-SHAPELY_SUPPORTS_BUFFER = shapely.geos.geos_capi_version >= (1, 6, 0)
+#SHAPELY_SUPPORTS_BUFFER = shapely.geos.geos_capi_version >= (1, 6, 0)
+# The geos_capi_version check fails with Shapely 1.5.12 & GEOS 3.5.0,
+# GEOS >= 3.1.1 has CAPI >= 1.6.0 and that's been in Debian for a while.
+SHAPELY_SUPPORTS_BUFFER = True
 
 def validate_and_simplify(geom, meter_units=False):
     if SHAPELY_SUPPORTS_BUFFER: