Package: inkscape / 1.0.1-1

Metadata

Package Version Patches format
inkscape 1.0.1-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
check for atomic.patch | (download)

CMakeScripts/DefineDependsandFlags.cmake | 16 16 + 0 - 0 !
1 file changed, 16 insertions(+)

 add -latomic where needed
 This is to fix the build on armel and mipsel
python3.patch | (download)

src/extension/implementation/script.cpp | 6 4 + 2 - 0 !
1 file changed, 4 insertions(+), 2 deletions(-)

 don't consider `python` a valid python[23]? interpreter.
 Just to be safe, don't even try to look it up.
 Should be safe to drop the patch once python2 is not around anymore.
avoid syntaxwarning in python extension.patch | (download)

share/extensions/interp.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 avoid syntaxwarning in a python extension
 I also reckon the chances of the check actually passing while using `is` to be quite low…
Forwaded: no, this is already upstream but not (yet) in the 1.0.x branch.
Last-Updated: 2020-09-10