Package: ipywidgets / 6.0.0-4

Metadata

Package Version Patches format
ipywidgets 6.0.0-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Unconditionally import setuptools to pick up depende.patch | (download)

setup.py | 3 1 + 2 - 0 !
widgetsnbextension/setup.py | 3 1 + 2 - 0 !
2 files changed, 2 insertions(+), 4 deletions(-)

 unconditionally import setuptools to pick up dependencies


0002 Don t build extension.js in widgetsnbextension setup.patch | (download)

widgetsnbextension/setup.py | 10 0 + 10 - 0 !
1 file changed, 10 deletions(-)

 don't build extension.js in widgetsnbextension/setup.py, since it
 will be done manually


0003 Use local MathJax.patch | (download)

docs/source/conf.py | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 use local mathjax


0004 Tweak package.json so the upstream build works in De.patch | (download)

jupyter-js-widgets/package.json | 1 0 + 1 - 0 !
widgetsnbextension/package.json | 2 1 + 1 - 0 !
2 files changed, 1 insertion(+), 2 deletions(-)

 tweak package.json so the upstream build works in debian

We don't actually use this in d/rules, but patch it anyway as a reference for
package maintainers.

- jupyter-js-widgets: "dedupe" fails on my machine, it's optional anyways
- widgetsnbextension: make sure we didn't accidentally download a remote one

0005 Import specific jupyterlab service types so we only .patch | (download)

jupyter-js-widgets/src/manager-base.ts | 11 7 + 4 - 0 !
jupyter-js-widgets/src/services-shim.ts | 2 1 + 1 - 0 !
2 files changed, 8 insertions(+), 5 deletions(-)

 import specific @jupyterlab/service types so we only have to bundle
 those