Package: jakarta-jmeter / 2.13-4

Metadata

Package Version Patches format
jakarta-jmeter 2.13-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_improve_cli_help.patch | (download)

build.xml | 2 1 + 1 - 0 !
src/core/org/apache/jmeter/JMeter.java | 13 7 + 6 - 0 !
src/core/org/apache/jmeter/examples.txt | 19 19 + 0 - 0 !
3 files changed, 27 insertions(+), 7 deletions(-)

 improves the help displayed on the command line
02_disable soap sampler.patch | (download)

build.xml | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 disable the soap sampler since it relies on the old apache soap api
 which isn't packaged yet. This library is archived here:
 http://archive.apache.org/dist/ws/soap/version-2.3.1/
03_disable jdbc module.patch | (download)

build.xml | 4 3 + 1 - 0 !
1 file changed, 3 insertions(+), 1 deletion(-)

 disable the jdbc components since it relies on the excalibur-datasource library
 which is not packaged yet
05_ignore jodd.patch | (download)

src/components/org/apache/jmeter/extractor/HtmlExtractor.java | 6 3 + 3 - 0 !
src/components/org/apache/jmeter/extractor/JoddExtractor.java | 102 0 + 102 - 0 !
src/protocol/http/org/apache/jmeter/protocol/http/parser/LagartoBasedHtmlParser.java | 242 0 + 242 - 0 !
3 files changed, 3 insertions(+), 347 deletions(-)

 disable the joddextractor since jodd isn't in debian yet
06_link to system javadoc.patch | (download)

build.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 link the api documentation with the system javadoc provided by the default-jdk-doc package
07_ignore tika.patch | (download)

src/core/org/apache/jmeter/util/Document.java | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 disable the code using apache tika until it's in debian
08_bouncycastle 1.51.patch | (download)

src/components/org/apache/jmeter/assertions/SMIMEAssertion.java | 22 13 + 9 - 0 !
src/components/org/apache/jmeter/assertions/SMIMEAssertionTestElement.java | 5 5 + 0 - 0 !
2 files changed, 18 insertions(+), 9 deletions(-)

 bouncycastle 1.51

Fix FTBFS with bouncycastle >= 1.51. This is apparently fixed in the
development version of jmeter. The patch can be dropped with jmeter 2.14.

09_httpcomponents compatibility.patch | (download)

src/protocol/http/org/apache/jmeter/protocol/http/sampler/MeasuringConnectionManager.java | 15 15 + 0 - 0 !
1 file changed, 15 insertions(+)

 fix the compatibility with httpcomponents-client >= 4.3
10_xstream compatibility.patch | (download)

bin/templates/templates.xml | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 remove the doctype to fix an error with xstream >= 1.4.9 (external entities are disabled)
11_java9 compatibility.patch | (download)

src/core/org/apache/jmeter/gui/tree/JMeterTreeNode.java | 2 1 + 1 - 0 !
src/jorphan/org/apache/jorphan/gui/JTreeTable.java | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 fixes the compilations errors with java 9
12_mongodb compatibility.patch | (download)

src/protocol/mongodb/org/apache/jmeter/protocol/mongodb/config/MongoSourceElement.java | 5 1 + 4 - 0 !
src/protocol/mongodb/org/apache/jmeter/protocol/mongodb/mongo/MongoDB.java | 27 13 + 14 - 0 !
src/protocol/mongodb/org/apache/jmeter/protocol/mongodb/sampler/MongoScriptRunner.java | 7 0 + 7 - 0 !
3 files changed, 14 insertions(+), 25 deletions(-)

 fixes the compatibility with the version of the mongodb java driver in debian (untested! feedback welcome)