Package: jed / 1:0.99.19-7

Metadata

Package Version Patches format
jed 1:0.99.19-7 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
README.patch | (download)

doc/README | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
jed manpage.patch | (download)

doc/manual/jed.1 | 68 40 + 28 - 0 !
1 file changed, 40 insertions(+), 28 deletions(-)

---
improve info files.patch | (download)

info/jed.1in | 5 5 + 0 - 0 !
info/jed.2in | 5 5 + 0 - 0 !
info/jed.3in | 5 5 + 0 - 0 !
info/jed.info | 1 1 + 0 - 0 !
4 files changed, 16 insertions(+)

---
check for lib terminfo.patch | (download)

autoconf/aclocal.m4 | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 check for /lib/terminfo in addition to other directories
 The configure script tries to run "ncurses5-config --terminfo", and if
 this does not succeed, uses a hardcoded list of terminfo directories
 which unfortunately does not include the directories /etc/terminfo and
 /lib/terminfo which we ship in ncurses-base.  Failing to find a terminfo
 directory, it then concludes that the system must be using termcap and
 adds "-ltermcap" to the linker line which fails.
 .
 To avoid this problem, add /lib/terminfo to the list of directories to
 search.
update Makefile.patch | (download)

autoconf/Makefile.in | 8 2 + 6 - 0 !
1 file changed, 2 insertions(+), 6 deletions(-)

 hacky fix for autotools issues
 We patch the configure script in order to find the terminfo library
 in the Debian location. However doing this cause a build failure
 because the below "Makefile is older than the configure script" check
 is triggered, and the build aborts.
 This should all be fixed by a proper autoreconfing, but some work is
 neeed to get that working as the autofoo is old. In the meantime
 simply nobbling the offending test does the job as everything still
 works.