Package: jffi / 1.2.7-11

Metadata

Package Version Patches format
jffi 1.2.7-11 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
disable MODEL in makefiles.patch | (download)

jni/GNUmakefile | 4 2 + 2 - 0 !
libtest/GNUmakefile | 4 2 + 2 - 0 !
2 files changed, 4 insertions(+), 4 deletions(-)

---
disable warnings as errors for jni.patch | (download)

jni/GNUmakefile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable warnings as errors for jni
 Remove the default use of -Werror when building the jni native
 extensions as expecting a warning-free build of cross-platform
 software is a bit of a fairy tale really.
junit_path_for_tests.patch | (download)

build.xml | 9 6 + 3 - 0 !
1 file changed, 6 insertions(+), 3 deletions(-)

---
disable warnings as errors for libtest.patch | (download)

libtest/GNUmakefile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
test_fork_true.patch | (download)

build.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
remove unnecessary target for native build.patch | (download)

build.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 remove unnecessary target for native build
nonlinux platforms.patch | (download)

build.xml | 7 7 + 0 - 0 !
jni/jffi/endian.h | 2 1 + 1 - 0 !
2 files changed, 8 insertions(+), 1 deletion(-)

 just use platform=linux for gnu/kfreebsd and hurd
Bug-Debian: http://bugs.debian.org/808175


java10 compatibility.patch | (download)

build.xml | 20 3 + 17 - 0 !
src/main/java/com/kenai/jffi/ObjectBuffer.java | 2 2 + 0 - 0 !
version.xml | 3 3 + 0 - 0 !
3 files changed, 8 insertions(+), 17 deletions(-)

 fixes the build failure with java 10