Package: jflex / 1.8.2-1

Metadata

Package Version Patches format
jflex 1.8.2-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
build.patch | (download)

pom.xml | 10 10 + 0 - 0 !
1 file changed, 10 insertions(+)

 build

Build-depend on Debian's jflex and cup artifacts.

LexScan.java.patch | (download)

src/main/java/jflex/core/LexScan.java | 3262 3262 + 0 - 0 !
1 file changed, 3262 insertions(+)

 lexscan.java

The current version of jflex 1.7.0 does not create LexScan.java correctly which
leads to multiple errors. Use jflex 1.8.2 to create LexScan.java. Drop the
patch as soon as 1.8.2 hits unstable and then reupload a new revision. Make
sure the package has migrated to Ubuntu before doing that.

auto value.patch | (download)

pom.xml | 13 13 + 0 - 0 !
1 file changed, 13 insertions(+)

 auto value

Ensure the AutoValue class is really build from source, otherwise this will
cause a FTBFS.

jflex executable.patch | (download)

bin/jflex | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 jflex-executable

Use Debian's system jflex.jar.

privacy breach.patch | (download)

doc/manual.html | 3 0 + 3 - 0 !
1 file changed, 3 deletions(-)

 privacy breach

Make Lintian happy.