Package: julia / 0.4.7-6

use-libjs-modernizr.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Description: Use libjs-modernizr package inplace of external link.
 This resolves a potential privacy breach by fetching data from
 an external website at runtime, as indicated in a lintian hint.
 The script is included as a static file by sphinx-rtd-theme.
Author: Peter Colberg <peter@colberg.org>
Forwarded: not-needed
Last-Update: 2014-10-22
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/doc/juliadoc/juliadoc/theme/julia/layout.html
+++ b/doc/juliadoc/juliadoc/theme/julia/layout.html
@@ -72,7 +72,7 @@
   {%- block extrahead %} {% endblock %}
 
   {# Keep modernizr in head - http://modernizr.com/docs/#installing #}
-  <script src="https://cdnjs.cloudflare.com/ajax/libs/modernizr/2.6.2/modernizr.min.js"></script>
+  <script src="{{ pathto('_static/js/modernizr.min.js', 1) }}"></script>
 
 </head>