Package: junit4 / 4.12-4

Metadata

Package Version Patches format
junit4 4.12-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
maven2 compatibility.patch | (download)

pom.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 remove the prerequisite on maven 3
exclude dependency sources.patch | (download)

pom.xml | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 don't include hamcrest in the javadoc (the source artifact isn't available)
Version.java.patch | (download)

src/main/java/junit/runner/Version.java | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 version.java

Work around to avoid the build-depends on the maven replacer plugin which
causes a FTBFS for unknown reasons.

Bug: https://bugs.debian.org/808494
privacy breach logo.patch | (download)

doc/homepage.html | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 privacy breach logo

Fix Lintian error:
https://lintian.debian.org/tags/privacy-breach-logo.html